Archive for AudiSRS.com The place for Performance Audi
 


       AudiSRS.com Forum Index -> Audi S3 (8L) quattro
guymcc

ABS light on! and other weird happenings!

Well this morning i had a bit of an interesting one!

Drove the car 10yds and the red warning exclamation light comes on, along with the yellow abs light and the yellow warning triangle!!

hmm reverse back in to the house, grab vagcom and hook it up. It wont connect to the abe module. hmm. So do a full scan and the first things that comes up on the engine module is code 18057..powertrain data bus.....missing message from abs controller!

Hmm not good, i clear the fault code, and then it immediately comes back on. So clear it again, and this time it stays away!

So get going in the car again....(along with the missus, and two kids on the back..getting late!!) and within 10yds the lights come back on!

So sod it, drive in th aberdeen anyway...On the way, the weird things start happening...first the red warning clears, comes back on x about 10. then this stays off and the yellow lights start flickering...and occasionally they come back on with the red light too. Also thrown in with this the rev needle drops off to zero, momentarily and comes back to normal. The rev needle isn't flicking, its zero or normal.

Anyway keep going and after about ten mintues more driving, everything clears and its as if nothing has happened!! Lights stayed off for remainder off journey, another 10 minutes say.

Not sure how the car is now, the wife is driving it back from Aberdeen!!

So basically.. has anyone any idea what is going on here!!!

TIA
Cheempeej

Old battery or any battery issues?

Symptoms of a dodgy battery can be random lights/warning combo
guymcc

Well the battery went flat the other day, as i left the ignition on over night.  I did think about this, but a suppose i dismissed it as i have been running the car for about a four days now without issue, only today has the lights come on.  hmmmm
quattrokid

I assume the brake fluid res. is at the correct level ?

Its jealous your spending more time in the 🚕💨 than it 😂🚗💨💨💨
guymcc

quattrokid wrote:
I assume the brake fluid res. is at the correct level ?

Its jealous your spending more time in the 🚕💨 than it 😂🚗💨💨💨

Eh? who's it?

I'm talking about the S3!
quattrokid

😳 Oh aye! I didn't notice that      
veedubliam

Bad connection or moisture somewhere or start of abs module failure?
Check the usual first to eliminate; battery and charge system, fuses for bad/ loose connections above the battery, abs module plug for bad or damp connections?
veedubliam

Whats a full system scan throw back at you? Any other missing modules, or stored codes?
veedubliam

Whats a full system scan throw back at you? Any other missing modules, or stored codes?
       AudiSRS.com Forum Index -> Audi S3 (8L) quattro
Page 1 of 1