Archive for AudiSRS.com The place for Performance Audi
 


       AudiSRS.com Forum Index -> Audi S4 & RS 4 (B5) quattro
TurboTy

ECU Loom - Wire cut?

Whilst unplugging my ECU I noticed one of the wires was cut. I don't have a picture at the moment but it is a solid yellow wire and it is cut right next to one of the plugs going into the ECU.

I have been having trouble connecting to the car through the diagnostics port so I'm hoping this could be the culprit.

Can anyone shed some light on the wiring loom to the ECU and perhaps what this wire does?

Thanks in advance
Rick

The K line for the ECU is pin 43 of the larger plug, and is green with a black stripe.

Rick
TurboTy

Rick wrote:
The K line for the ECU is pin 43 of the larger plug, and is green with a black stripe.

Rick


Darn, thanks for the info

Everything else seems to be working, the mystery continues
Aragorn

yellow is the color of a VAG harness repair wire... It might not be original?
madmax2

i read here somewhere that if you have a non-standard radio you may have trouble connecting to diagnostics as they ground the K-line wire in some harnesses.
hope this helps.
TurboTy

madmax2 wrote:
i read here somewhere that if you have a non-standard radio you may have trouble connecting to diagnostics as they ground the K-line wire in some harnesses.
hope this helps.


Aftermarket radio does, ABS unit can also cause problems. There are several threads on it.

I'll post a picture at the weekend of the wire in question, still interested to find out why it was cut!
TurboTy

The wires in question

Aragorn

you'll need to take the connector back housing off and see where they go.
TurboTy

The yellow wires pictured are additional to the loom.

In the invoice for the remap at MRC there is a line for temporary wiring into the ecu. This looks to be what this is.

One wife is spliced into the k line (green and black)

There are two yellow wires spliced into a blue and black wire. Does anyone know what this does?

I wonder whether the k line wire was shorting on something, will make sure it is properly insulated...
IchBautAuto

TurboTy wrote:
The yellow wires pictured are additional to the loom.

In the invoice for the remap at MRC there is a line for temporary wiring into the ecu. This looks to be what this is.

One wife is spliced into the k line (green and black)

There are two yellow wires spliced into a blue and black wire. Does anyone know what this does?

I wonder whether the k line wire was shorting on something, will make sure it is properly insulated...


How many wives do you have
Aragorn

pretty rough of MRC to have left it like that?! wasnt it insulated up?

solid black is usually ignition live. blue could be anything.

I suspect the K-Line in the car is broken (due to some other faulty module etc) and they've been forced to do that to get comms with the ECU for the remap.
TurboTy

Aragorn wrote:
pretty rough of MRC to have left it like that?! wasnt it insulated up?

solid black is usually ignition live. blue could be anything.

I suspect the K-Line in the car is broken (due to some other faulty module etc) and they've been forced to do that to get comms with the ECU for the remap.


It was wrapped up and insulated as far as I could tell, clutching at straws a little...

Yeah, it sounds like the k line has been broken for some time, the search continues  
       AudiSRS.com Forum Index -> Audi S4 & RS 4 (B5) quattro
Page 1 of 1