Archive for AudiSRS.com The place for Performance Audi
 


       AudiSRS.com Forum Index -> Audi S4 & RS4 (B5) quattro
GS

ESP/Traction Control Light

Just wondered if anyone else has experienced this or can shed any light on it.

In my S4 Avant in the last few days when accelerating quite hard in third gear the light has come on/power cut (feels like a rev limiter) at about 5500rpm. The first time was a wet A43 so thought nothing more of it but both times since have been dry conditions, straight line and slight inclines. Seems really odd as have done quite a bit of accelerating quite hard and everything has been normal!?!

Cheers
ScottR

Can a faulty MAF not cause this?
Big Andy W

it just cuts in too early, even the slightest hard excel caused this on mine, 1 way to fix it is to close door, fasten seat belt switch off ESP, you'll never lose control of 1 of these cars if only slightly modded! :

...i've had a beer or 7 so please don't use this evidence in court! lol
derdle

Simple things first...are your tyres OK?
Inflated to correct pressure?
Not unduly worn?
Decent manufacturer?

After a bit of a dry spell (we had 3 days didn't we?) some grease/diesel could have been left on the road surface that may have caused the tyres to lose grip.

If you've been used to giving the car some beans then the tyres take it all and could have worn.

Paul
loomx

My mates S4s traction control was over cautious and it was because of a dead MAF
DavidT

I seem to remember someone having this problem with a mix of tyre types.
MarkB

DavidT wrote:
I seem to remember someone having this problem with a mix of tyre types.


Yep, mine cuts in a lot and I'm running different tyres front and rear. Not excessive power either.

Can also be a dirty sensor or split abs ring
GS

Thanks for the replies guys.

It has four Eagle F1s on which have done about 500 miles, could it be because they are newish? . Only had the car for a month and it was serviced by Hemel Audi in March and on the receipt it says the MAF was changed (is there more than one?)

Should also mention that a couple of weeks ago it was health checked/remapped by the awesome MRC. Will keep an eye it/turn the esp off, was surprised by what was probably the placebo effect, but it felt more lively
derdle

There is only one MAF on the car and since Doug has health-checked the car I think you can be pretty certain that everything is in order. So now it comes down to two/three things really....

1. The car has been remapped.
2. You are booting the car which now has a lot more more power.
3. Tyres - I haven't any experience of the Eagles so not sure whether they are any good!
mikeyquattro

S4 XGS wrote:
Thanks for the replies guys.

It has four Eagle F1s on which have done about 500 miles, could it be because they are newish? . Only had the car for a month and it was serviced by Hemel Audi in March and on the receipt it says the MAF was changed (is there more than one?)

Should also mention that a couple of weeks ago it was health checked/remapped by the awesome MRC. Will keep an eye it/turn the esp off, was surprised by what was probably the placebo effect, but it felt more lively


That rules your MAF out then!
Let the tyres scrub in a bit more, but I suspect it's because of the map. I nearly always turn my esp off in the dry  
James

Might be the brake light swtich
Paz

James has a good point with the brake switch, it may still be a faulty MAF though, they can go off pretty quickly.

I had a similar problem with ABS/ESP lights, turned out to be oxidised contacts on the ABS electronic control unit (attached to the main unit on my facelift S4). I had the contacts cleaned and that cured it.
Incidently my Cruise Control was also affected as it went into failsafe mode (read inoperable) with the ABS being faulty.

Get it checked out for peace of mind.
mikeyquattro

Would a MAF go off in 2 weeks Paz?
derdle

Surely a faulty MAF would show the ESP/ABS lights continuously? The OP says that the lights only come on when accelerating (hard).

Paul
loomx

My mates traction controll seem to just cut in more when his maf was on the way out. Dont know why.
Paz

Mikey, I know of two instances where a new MAF has been faulty, luckily both specialists had many in stock.

Derdle, you do indeed have a good point - my bad.
James

I had a similar problem and Audi changed the brakes light switch under warrenty and the problem went away.
GS

Paz wrote:
Mikey, I know of two instances where a new MAF has been faulty, luckily both specialists had many in stock.

Derdle, you do indeed have a good point - my bad.


I reckon it has to be worth getting it checked by someone with Vagcom to see what faults come up then, as the MAF was replaced by Hemel Audi in March they should offer to replace again if it is the problem. On that note is there anyone willing to help me that has Vagcom? Would gladly pay you for your time/take you out for a beer, I'm near Newbury in Berkshire.

With the ESP off today had no problems and the biggest grin on my face, never had a V6 before and only dark-side turbos so I am in my element at present. Haven't even bothered to put my CD collection in the car yet as just opening the window is music enough, just wish there were more tunnels and perhaps a Milltek system fitted
GS

Right then, finally sorted out getting a Vagcom lead etc...

Came up with the following fault

Address 01: Engine        Labels: 078-907-551-AZA.lbl
  Part No: 8D0 907 551 D
  Component: 2.7l V6/5VT         0002  
  Coding: 05711
  Shop #: WSC 06325  

1 Fault Found:
17862 - Exhaust Gas Temp Sensor 1 (G235): Short to Ground
           P1454 - 35-10 -  -  - Intermittent
Readiness: 0000 0000

I cleared it then went for a blat and it came back. Am I right in thinking there is only one EGT? Going to call MRC tomorrow to see what they suggest as they replaced it during the health check last month.
jimbo

theres 2 egts on these engines, when mine went because of a bad maf the car would go into limp mode once you reached 4k. turned out it was the pass side egt. about an hour to fix by me (a novice)
GS

Argh crap

Thanks Jimbo, is there an easy way to find out which one it is?
jimbo

ones got a red box ,ones got a black box . not sure which is which as it was a year ago and ive slept since then. someone will be along soon to answer this question.
GS

Back to MRC first thing Monday, just hope that I don't get tempted into anything else while I am there
       AudiSRS.com Forum Index -> Audi S4 & RS4 (B5) quattro
Page 1 of 1