Archive for AudiSRS.com The place for Performance Audi
 


       AudiSRS.com Forum Index -> Audi S4 & RS4 (B5) quattro
Sql

Mass Air Flow Sensor (G70): Signal too Low

I assume my MAF is officially gone then?
Byzan a4

yep, gone to the big skip in MAF heaven
Jonmurgie

What filter did you have fitted?    
Sql

Well this one worked almost 18 months so still pretty good I guess!
Sql

Jonmurgie wrote:
What filter did you have fitted?    


             

OEM paper one.
KiwiRS4

MAF Killer Dashboard

(OEM Paper) 1 : 0 (ITG Foam Filter)

Let the games begin...

Sql wrote:
Jonmurgie wrote:
What filter did you have fitted?    


             

OEM paper one.
Aragorn

Sql wrote:
Well this one worked almost 18 months so still pretty good I guess!


Pretty good?

The MAF in my car is 10 years old.
The MAF in mums is 14 years old.

18 months is seriously crappy for a component like that, especially given you've said your running a paper filter.
Sql

I am on my 5th or 6th in 10 years. First 2-3 killed by K&N filter though.
Ash25

dont you get a 2 year warranty on these things?

Ash
paRS4

Before I found "the other side" and subsequently  this fine forum, I fitted a K&N to my S4, which I had recently cleaned and re-oiled (generously!).

Things went south very quickly. Cleaned MAF with IPA (not the Greanking kind!) and replaced paper filter, but MAF died shortly there after.

Lesson learned regarding oil on the MAF sensor.

Still have it in my garage. My first MAF.... ahhhh bless!
Doug

You need to check what the maf is reading before you bin it.
H714DHG

Is there a performance issue? Or does it simply mean that the plug has come off with the ign on at some point? Common for the clip on the plug to be broken as it gets hot and becomes brittle.

As above, check readings and make accurate diagnosis
Sql

Hmm car started to misfire at WOT giving loud explosions out of the exhaust... could that have any relation to MAF failure?
Rick

You may have an air leak. Sounds like a lean mixture if popping/banging so don't be going WOT or you will melt something!

Engine uses the secondary load signal when MAF fails, but the calibration is often out on a remapped car.

Rick
H714DHG

Rick wrote:

Engine uses the secondary load signal when MAF fails, but the calibration is often out on a remapped car.

Rick


Really?
Rick

H714DHG wrote:
Rick wrote:

Engine uses the secondary load signal when MAF fails, but the calibration is often out on a remapped car.

Rick


Really?


yes, more so if different injectors or fuel pressures are used.  The tuner doesn't map the car without the MAF connected in most instances.

Rick
Sql

Well it looks like popping/banging was prob caused by coilpacks. Ordered new set, we will see if it helps.
       AudiSRS.com Forum Index -> Audi S4 & RS4 (B5) quattro
Page 1 of 1