AudiSRS.com
 Home  •  Forums  •  New Posts  •  Search  •  Classifieds  •  Insurance  •  Advertisers  •  Shop  •  Profile  •  Log in to check your private messages  •  Log in   •  Join! (free)
The free forums are now under new ownership, a full announcement will be made shortly
 Cooling fans not coming on View next topic
View previous topic

Post new topicReply to topic
Author Message
Glekke
knowledgeable


Car: S4 B5
Power: stock
Torque: stock
Engine code: AZR

Joined: 22 May 2013
Posts: 254

Location: Belgium

PostPosted: Mon Mar 20, 2017 2:15 pm  Reply with quoteBack to top

Since I put an RS4 engine with complete harness in my s4 pfl, my cooling fans don't work any more, so the car is running hot.
I haven't touched the control module and the fans are still the same ones that where there before...

Any thoughts on this?
What to try first?
View user's profileSend private message
Jism
Knows a Bit


Car: 2001 RS4 B5

Joined: 29 Oct 2016
Posts: 216

Location: Holland

PostPosted: Mon Mar 20, 2017 3:18 pm Reply with quoteBack to top

1: Check fancontroller.

2: Check blue sensor on the bottom coolant line.

Proberly #1 as fan controllers die easily. They are not cheap.
View user's profileSend private message
Aragorn
Veteran


Car: 1.8TQS Avant

Joined: 06 May 2010
Posts: 9936

Location: Glenrothes

PostPosted: Mon Mar 20, 2017 7:10 pm Reply with quoteBack to top

the fans are completely seperate to the engine harness anyway...

Unless you changed the whole body harness?

Theres a big fuse under the dash, and otherwise the controller under the chassis leg controls everything else.
View user's profileSend private message
Glekke
knowledgeable


Car: S4 B5
Power: stock
Torque: stock
Engine code: AZR

Joined: 22 May 2013
Posts: 254

Location: Belgium

PostPosted: Mon Mar 20, 2017 9:55 pm Reply with quoteBack to top

Will check fuses tomorrow. Any way to test the fan controller?
View user's profileSend private message
Jism
Knows a Bit


Car: 2001 RS4 B5

Joined: 29 Oct 2016
Posts: 216

Location: Holland

PostPosted: Mon Mar 20, 2017 10:06 pm Reply with quoteBack to top

Yes,

On the bottom coolant line, there's a blue sensor in one of the hoses. Pull that wire (connector) and use a paperclip to short pin 1 & 2 for low, pin 3 & 4 for high.

If the fans dont come on, the fan controller is bricked.



That is a reference picture of the fancontroller. It's on the right of the front car, underneath one of the beams. Hard to reach, expensive little bugger.

- Edit: Or you can just turn on the airco. If the front left fan spins up, the fan controller seems to work.
View user's profileSend private message
jamiehamy
knowledgeable


Car: S4 B5 Avant LPG
Power: 265bhp

Joined: 21 Sep 2011
Posts: 326

Location: Gourock

PostPosted: Mon Mar 20, 2017 10:39 pm Reply with quoteBack to top

Does the RS engine have a viscous fan?

_________________
'04 Mini Cooper
'99 Audi S4 B5 on LPG
'93 VW Corrado VR6
'88 VW Transport T25 1.7d
View user's profileSend private message
Aragorn
Veteran


Car: 1.8TQS Avant

Joined: 06 May 2010
Posts: 9936

Location: Glenrothes

PostPosted: Mon Mar 20, 2017 10:51 pm Reply with quoteBack to top

i believe it should start both fans, even with just the AC on?
View user's profileSend private message
Aragorn
Veteran


Car: 1.8TQS Avant

Joined: 06 May 2010
Posts: 9936

Location: Glenrothes

PostPosted: Mon Mar 20, 2017 10:51 pm Reply with quoteBack to top

jamiehamy wrote:
Does the RS engine have a viscous fan?


Yes, all B5's have one.
View user's profileSend private message
Jism
Knows a Bit


Car: 2001 RS4 B5

Joined: 29 Oct 2016
Posts: 216

Location: Holland

PostPosted: Mon Mar 20, 2017 11:41 pm Reply with quoteBack to top

Aragorn wrote:
i believe it should start both fans, even with just the AC on?


The only fan going on with AC is the fan on the front left. The big fan on the front right (front mounted) jumps in when engine is becoming hot, both low and high speeds, and at some point the AC fan might kick in to provide additional cooling if i'm not mistaken.

The cooling on both S4/RS4 B5 is pretty beefy, with that viscous fan in front as well.

As i wrote before, you can test the front right fan mounted up front by accessing the blue sensor on the bottom left of the radiator hose, unplug the connector, put a paperclip in there and short 1-2 and 3-4 for testing low/high-speed.

If the fancontroller is dead, that fan is not coming on. If the fancontroller works, then the fan comes alive. If it works but is not switching when the engine is overheating, that sensor might be damaged.
View user's profileSend private message
Display posts from previous:      
Post new topicReply to topic

Share |

 Jump to:   


View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum






Powered by phpBB phpBB Group



AudiSRS.com is not affiliated with Audi in any way. The Audi name and logos are registered trademarks of Audi
The content on this website has not been endorsed by Audi, nor has it been verified for correctness by AudiSRS.com.
All other logos and trademarks in this site are property of their respective owners.
The comments are property of their posters, all the rest are copyright by AudiSRS.com